
Müasir proqramla rman n saslar : Excel&VBA
(MicroSoft texnologiylar )

II f sil. Visual Basic for Aplication (VBA)

Visual Basic (VB) redaktoru
Bu bölm  biz VB redaktorunun imkanlar  il  tan  olaca q. Redaktorun

ilkin kod p nc si
UserForm dialoq p nc si
sazlama p nc ri
Menyu v  al tl r paneli alt-sisteml ri

imkanlar  öyr nm kl  g kd  yarad lacaq sisteml rin daha sür tl  v  effektiv haz rlanmas  i in
yard m ed k. Ümumiyy tl  MicroSoft irk ti müxt lif sisteml rind  istifad çi üçün maksimum i

raiti yaratma a çal r. Eyni bir i i bir neç  alternativ metodla yerin  yetirm k mümkündür.
stifad çi özü i  metodunu özü mü yy n edir1.

VB redaktorunun yükl nm si
VB redaktoru Excel sisteminin daxilind  xüsusi menyu rejimi v  ya Visual Basic al tl r
menyusundan ça r. VB redaktoru VBA proqramla rma üçün n rd  tutulub. Burada as
olmayan llkin proqram kodlar  il  yan  Excel kitab n müxt lif obyektl ril  i n ilkin proqram
kodlar  yazmaq olar. kil1-d  VBA redaktorunun yükl nm n sonrak  görünü ü verilib. VBA
redaktoru ayr ca p nc  yükl nir.
!!! Excel sisteminin ba lanmas  VBA redaktorunun p nc sinin avtomatik ba lanmas na g tirib

xar r.
!!! VBA redaktoru ASCII kodlar  il  i diyi üçün biz Az rbaycan m tnl rini ya ingilis lifbas la ya
da ngilis dilind  daxil ed yik.

kil1. VBA redaktorunun görün ü

VB-n n redaktoru, cüzi f rql ri n  almasaq, VB6 v  VB.NET alqoritmik dill rin redaktorlar na b nz yir. Bu
redaktorda proqramla rma üçün z ruri h r cür rait yarad b. ndi VB redaktorunun imkanlar  n rd n keçir k.

1 M n, lkin kodun y lmas  zaman  h m paneli menyusundan, h m “isti düym rd n”, h m d  al tl r panelind n
 ya qar q üsuldan istifad  etm k olar. Hans  metoddan/üsuldan istifad  etm k istifad çinin öz öhd sin  burax r.
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nc r
kil1-d  sol yuxar  küncd  yerl mi Project(Layih ) nc si – müasir proqramla rma

rd  tutulmu , h ll olunacaq m nin layih sini özünd  saxlayaraq, a dak  qruplardan
(qovluq kilind ) t kil olunub:

1. Excel kitab n obyektl ri
2. Modullar
3. Formalar
4. Sinifl r

Bu qruplarla daha geni  qar dak  d rsl rd  tan  olaca q.
Code( lkin kod) p nc si. lkin kodlarla i k(y lmas , korrekt si, sazlanmas ) üçün n rd
tutulmu  z ruri p nc . Complete Word, Intelli Sense kimi alt-sisteml r ilkin kodlar n sür tli v

hvsiz y lmas na yard m edir.
UserForm( stifad çi formas ) p nc si. Vizual kild  standart windows p nc rini yaratmaq,
idar etm  elementl rini lav  etm k üçün n rd  tutulub.
Properties(Xüsusiyy tl r) p nc si. Projest p nc sind  mövcud olan müxt lif
elementl rin(obyektl rin) xüsusiyy tl rini özünd  saxlay r. Proramla lan sistemin t bl ri
sas nda bu xüsusiyy tl ri d yi k mümkündür.

Immediate (D rh l yerin  yetirilm ) p nc si. VBA interpretator oldu u üçün n tic rin konsol
rejimind  görünm si üçün n rd  tutulmu  p nc dir. Bu p nc  VBA-n n funksiyalar  da
yoxlamaq olar. Müasir proqramla rma redaktorlar n ks riyy tind  bel  bir p nc  realiz
olunub. Bu p nc nin sas v zif rind n biri ilkin proqram kodunun sazlanmas na yard m
etm kdir. Layih  mövcud prosedur v  funksiyalar n ayr ca sazlanmas  i in  yard m edir.
Locals (Lokal d yi nl r) p nc si. Layih nin add m-add m(ilkin kodlar n sazlanma

rh sind ) yerin  yetirilm si zaman  lokal d yi nl ri v  onlar n ald  qiym tl ri göst rm k
üçün n rd  tutulub. Bu p nc sas n layih nin bütövlükd  v  ya modullar s viyy sind
sazlanmas  i ind  geni  istifad  olunur. Müasir proqramla rma redaktorlar n ks riyy tind  bel
bir p nc  realiz  olunub.
Watches (N car t) p nc si. Layih  realiz  olunmu  seçilmi yi nl  n zar t(izl nm )
üçün n rd  tutulub. B zi hallarda proramla rman n sazlanmas  vaxt nda z ruri bir al  çevrilir.
Amma bu p nc Locals p nc sind n daha az istifad  olunur. Müasir proqramla rma
redaktorlar n ks riyy tind  bel  bir p nc  realiz  olunub.
Call Stack(Ünvanlar yadda ) p nc si. Bu p nc  vasit sil  layih nin add m-add m yerin
yetirilm  m rh sind  hans  prosedur v  funksiyalar n aktiv olmas  mü yy n etm k olar. Bu

nc  dinamik xarakterli olub, laz m olanda View menyusundan ça r.
Object Browser (Obyektl rin Bax ) p nc si. Bu p nc  informativ xarakter da b,
Excel&VBA-da reliz  olunmu  bütün obyekt, sinif, sabitl r, metodlar, xususiyy tl r haqq nda

ruri m lumat ld  etm k üçün n rd  tutulub. Pe kar proqram sisteml ri yaratmaq üçün z ruri
nc /sistemdir.

VB redaktorunun menyusu

File
Save <project> Ctrl+S Mövcud layih ni v  onun bütün obyektl rini, o

cüml n Excel kitab  v  VBA obyektl rini,
HDD diskd  yadda saxlay r

Import File Ctrl+M Layih n k rda mövcud forma, modul, sinif
xarakterli fayllar  mövcud layih lav  edir.

Export File Ctrl+E Layih  mövcud forma, modul, sinif
obyektl rini m tni fayl kimi HDD-y  yazmaq
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üçün n rd  tutulub. Bu m tni fayllar  sonradan
“Import File” rejimi vasit sil  ba qa layih
lav  etm k olar.

Remove <item> VBA layih sind n seçilmi  h r hans  elementi
(forma, modul, sinif) l v etm k olar. Bu rejimd

v olunacaq elementin vv lc  eksport
olunmas  t min etm k olar.

Print
Çap etm k

Ctrl+P Seçilmi  forma, modul, sinif elementl rini çap
etm k üçün n rd  tutulub.

Close and Return to ... Alt+Q VB redaktorunu ba lay b, bu redaktoru ça ran
HOST sistem  qay tmaq.

Edit
Undo Ctrl+Z Sonuncu mri l v etm k üçün n rd  tutulub.

Ayd nd r ki, r stek bo dursa bu rejim yerin
yetirilm k.

Redo Sonuncu l v olunmu mri t krar yerin
yetirm k üçün n rd  tutulub.

Cut Ctrl+X tni v  ya forman n obyektini l v ed k onu
Windows Clipboard yadda na yerl dirir.

Ctrl+C tni v  ya forman n obyektini Windows
Clipboard yadda na yerl dirir. Bu zaman m tn

 ya obyekt d yi mir.

Paste Ctrl+V Windows Clipboard yadda ndak  m tni v  ya
obyekti aktiv modul v  ya formaya yerl dirir.

Clear Del ar nmi  m tn v  ya obyekti l v etm k üçün
rd  tutulub.

Select All Ctrl+A Bütün m tnin v  ya formadak  bütün obyektl rin
ar nm si üçün n rd  tutulub. Sonradan bu
ar nmi  qurup üz rind  müxt lif liyyatlar

aparmaq olar.

Find Ctrl+F Modul(lar)da h r hans  bir m tnin axtar lmas
üçün n rd  tutulub.

Find Next F3 Axr nc  Find mrini t krarlay r.

Replace Ctrl+H Modul(lar)da h r hans  bir m tnin axtar b
dig rbir m tnl  d yi dirilm si üçün n rd
tutulub.

Indent Tab Kursorun mövqeyind n s tri v  ya i ar nmi
trl ri tabuyasiyan n ölçüsü q r sa a ç km k

üçün istifad  olunur.
VB redaktoru "art q" probel v
tabulyasiyalar  avtomatik l v edir.

Outdent Shift+Tab Kursorun mövqeyind n s tri v  ya i ar nmi
trl ri tabuyasiyan n ölçüsü q r sola ç km k

üçün istifad  olunur.
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List Properties/Methods Ctrl+J Modula daxil etdiyiniz obyektin ad na uy un
mümkün xüsusiyy t v  ya metodlar siyahisini
göst rir. Bu rejim avtomatik olaraq yükl nir.
Proqram n ilkin kodlar n y lma sür tinin
artmas na yard m edir.
Kursor bo  yerd  olark n bu rejim mümkün olan
bütün metod v  xüsusiyy tl rin siyahisini
göst rir.

List Constants Ctrl+Shift+J Seçilmi  VBA obyektinin modula daxil ed rk n,
sintaksisind  n rd  tutulmu  sabit parametrl ri
mü yy nl dirilm sin  yard m ed n siyahi. lkin
kod y lan zaman  bu siyahi avtomatik görs nir.
Siyahini uy un mövqed n “List Constants”
rejimini vasit sil  d  yükl k olar.

MsgBox(prompt[, buttons] [, title] [,
helpfile, context])
daxili funksiyas n buttons parametri
sabitdir v  y m zaman bu mövqey
yax nla anda "List Constants" rejimi
avtomatik olaraq seçim üçün uy un
siyahini ç xar r.

Quick Info Ctrl+I Modula daxil edilmi  prosedur, funksiya,
metodun düzgün sintaksisini göst rm k üçün

rd  tutulub. Y m zaman  bu rejim
avtomatik olaraq yükl nir.
Art q y lm  VBA obyekti haqq nda m lumat
ld  etm k üçün “Quick Info” rejimind n istifad

olunur.

Parameter Info Ctrl+Shift+I Modula daxil edilmi  prosedur, funksiya,
metodun parametrl rinin(arqumentl rin)
qiym tl rini göst rm k üçün n rd  tutulub.

Complete Word Ctrl+Space VB redaktoru bu rejim vasit sil  daxil edil n
sözl ri tamamlamaq üçün n rd  tutulub.

n, msg h rf lrini daxil ed nd n sonra
“Ctrl+Space” düym rini s xanda MsgBox sözü
avtomatik olaraq tamamlan r.

Bookmarks ( ) ri ölçülü ilkin kodlarda istifad  olunur. lkin
kodun laz mi s tirl rind  “Toogle Bookmark”
alt-rejimi vasit sil  xüsusi qeydl r
yerl dirilir/götürülür. Bu qeydlr  üzr  h t
etm k üçün, y ni ilkin kodun laz m olan s trin
keçm k üçün “Next Bookmark” v  “Previous
Bookmark” alt-rejiml rind n istifad  etm k olar.
Qeydl ri l v etm k üçün “Clear All
Bookmarks” altrejimind n istifad  etm k olar.
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View
Code F7 Seçilmi  modul v  ya forman n ilkin kodlar

Code Window p nc sind  göst rir.

Object Shift+F7 Obyektin vizal variant na keçid üçün istifad
olunur(UserForm).

Definition Shift+F2 VBA-n n obyektl rinin xüsusiyy t v
metodlar n sintaksisini Object Browser-d
göst rir.(?????)

Last Position Ctrl+Shift+F2 Kursorun vv lki v ziyy tin  qay r.(?????)

Object Browser F2 Obyektl , onlar n xüsusiyy t v  metodlar na
baxmaq üçün Object Browser p nc sini aç r.
Burada h m VBA-n n h m d , konkret olaraq
aktiv layih nin metod v  xüsusiyy tl rinin
sintaksisini görm k olar.

Immediate Window Ctrl+G lkin kodlar  sazlamaq üçün n rd  tutulmu
Immediate p nc sini aç r.

Locals Window lkin kodlar (lokal d yi nl ri) sazlamaq üçün
rd  tutulmu Locals Window p nc sini

aç r.

Watch Window lkin kodlara(seçilmi  lokal d yi nl ) n zar t
üçün n rd  tutulmu Watch Window

nc sini aç r.

Call Stack Ctrl+L VBA layih  yerin  yetiril rk n yükl nmi
funksiya v  prosedurlar n siyahisini göst n Call
Stack p nc sini aç r.

Project Explorer Ctrl+R Project Explorer layih  p nc sini göst rir. Bu
nc n layih nin müxt lif elementl ril

k mümükündür.

Properties Window F4 Layih  komponentl rinin  xüsusiyy tl ri
nc sini aç r.

Toolbox Toolbox al tl r paneli UserForm p nc si aktiv
olan zaman yükl nir v  bu al tl r vasit sil  dialoq
formas na yeni elementl r lav  etm k
mümükündür.

Tab Order Dialoq formas n elementl rini göst rir. V
ist nil n element (obyekt ) keçidi t min edir.

Toolbars VB redaktorunun müxt lif al tl r panell rini
özünd  saxlay r v  onlar n redaktorda
görs nm sin  v  ya gizl dilm sin  xidm t edir.

<Host application> Alt+Fll HOST( sas) sistem  keçid üçün n rd  tutulub.
Bu zaman VB redaktoru ba lanm r. <Host
application> Ofis proram sistemind n as  olaraq
müxt lif ola bil r. Bizim halda burada Microsoft
Excel görün k.
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Insert
Procedure Aç q modula yeni prosedurun (Sub, Function v

ya Property) lav  edir.

UserForm Layih  yeni UserForm dialoq formas lav
edir. Bu forman n ad  mü yy n olunmu  qaydada

yin olunur.

Module Layih  yeni ilkin kod sah si(Modulexxx) lav
edir. Bu modul sah sinin ad  mü yy n olunmu
qaydada t yin olunur.

Class Module Layih  yeni ilkin kod sinif sah si(Classxxx)
lav  edir. Bu modul sah sinin ad  mü yy n

olunmu  qaydada t yin olunur.

File tni fayl  ilkin koda lav  etm  imkan verir.

Format
Align UserForm dialoq formas ndak  seçilmi

elementl ri nizamlamaq üçün istifad  edil n
al tl r rejimi. Bu rejim vasit sil  elementl rin
ümumi formada yerl  v ziyy ti il  yana , bir-
birl rin  nisb n yerl sini nizamlamaq olar.

Make Same Size UserForm dialoq formas ndak  seçilmi
elementl rin ölçül rini nizamlamaq üçün istifad
edil n al tl r rejimi.

Size to Fit zmununa gör  seçilmi  elementin ölçüsünün
yi dirilm si.

Size to Grid Torun parametrl ri sas nda seçilmi
elementl rin ölçüsünün d yi dirilm si.

Horizontal Spacing UserForm dialoq formas ndak  seçilmi
elementl ri üfüqi istiqam td  nizamlamaq üçün

rd  tutulmu  al tl r rejimi.

Vertical Spacing UserForm dialoq formas ndak  seçilmi
elementl ri aquli istiqam td  nizamlamaq üçün

rd  tutulmu  al tl r rejimi.

Center in Form UserForm dialoq formas ndak  seçilmi
elementl rin formaya nisb n üfüqi v  ya aquli
istiqam td  m rk  g tirilm sin  xidm t edir.

Arrange Buttons UserForm dialoq formas ndak  seçilmi
düym rin b rab r intervalla forman n a nda

 ya sa nda yerl dirm k üçün n rd
tutulmu  al tl r rejimi.

Group UserForm dialoq formas ndak  seçilmi
elementl ri qrupla rmaq üçün n rd  tutulub.

Ungroup Qrupla lm  elementl rin qrupdan
xard lmas  üçün n rd  tutulub.
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Order UserForm dialoq formas ndak  bir-birl rinin
üstünü ört n elementl rin v ziyy tini mü yy n
etm k üçün n rd  tutulub. Y ni siz bu rejim
vasit sil  hans  elementin üstd , hans n altda
görs nm sini mü yy n ed  bil rsiz.

Debug
Compile <project> Aktiv layih nin kompilyasiya edir.

Step Into F8 lkin kodu add m-add m yerin  yetirm k üçün
rd  tutulub.

Step Over Shift+F8 Prosedurun bütün s trl rini alt-
prosedur/funksiyalara keçm n yerin  yetirir.

Step Out Ctrl+Shift+F8 Aktiv prosedurdan, onu ça ran prosedura
qay tmaq.

Run to Cursor Ctrl+F8 Kursorun yerl diyi s tr  q  bütün s trl ri
yerin  yetirir.

Add Watch yi ni v  ya ifad ni n zar td  saxlamaq üçün
onlar Watch Window p nc sin lav  edir.

Edit Watch Ctrl+W Add Watch vasit sil Watch Window
nc sin lav  edilmi  d yi n v  ifad ri

korrekt  üçün n rd  tutulub.

Quick Watch Shift+F9 Seçilmi  ifad nin mövcud qiym tini göst rir.

Toggle Breakpoint F9 lkin kodda dayanma nöqt sini mü yy n edir.
lkin kod yerin  yetiril rk n bu nöqt  g lib

çatanda proqram öz i ini dayand r. Proqramç
özün  laz m olan m lumatlar ld  ed nd n sonra
proqram n i ini b rpa ed  v  ya tamamil
dayand ra bil r.

Clear All Breakpoints Ctrl+Shift+F9 Bütün dayanma nöqt rini l v edir.

Set Next Statement Ctrl+F9 Yerin  yetirilm  ard ll  d yi k, kursorun
göst rdiyi s trd n proqram n yerin  yetirilm sini
göst rir.

Show Next Statement Növb ti yerin  yetiril k s tri göst rir.

Run
Run Sub/User Form F5 Bu rejim vasit sil  VB redaktorunda kursor

dayanm  proseduru v  ya aktiv UserForm-u
yerin  yetirir.

Break Ctrl+Break Yerin  yetiril n proqram  dayand r. sas n ilkin
kodlar n sazlanmas  zaman  yerin  yetirilir.

Reset <project> Modulun bütün d yi nl rini ilkin v ziyy
tirir v  Stack-i bo ald r.

Design Mode Layih nin Design mode rejimini qo ur v  ya
ay r. Bu rejim vasit sil  Excel kitab n
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hif rin  idar etm  elementl rini lav  ed rk n
onlar n yerin  yetirilm sinin qar  almaq olar.

ni bu rejim sas n s hif  idar etm
elementl ri yerl dir rk n v  onlar  sazlayark n
laz md r.

Tools
References Bu rejim kompüterd  mövcud olan b zi

sisteml rin obyektl rin , kitabxanalar na
istinadlar  verm k üçün n rd  tutulub. Bu
istinadlar Object Browser-d  öz ksini tap r.

n, Movie Maker sisteminin obyektl rin
istinad verm kl  Excel sistemind  video klipl rin
montaj  t kil etm k olar.

Additional Controls UserForm üçün n rd  tutulmu  Toolbox-a yeni
obyekt/elementl r lav  etm k olar.

Macros Macros-lar  yaratmaq, korrekt  etm k, yerin
yetirm k v  l v etm k üçün n rd  tutulub.

Options VB redaktornun parametrl rini mü yy n etm k
üçün n rd  tutulub.

<project> Properties Layih nin b zi ümumi xüsusiyy tl rini, o
cüml n, layih nin ad , kontekst köm yin

svirini v  köm k rejimini mü yy n etm k,
layih nin mühafiz sini t min etm k üçün istifad
olunur.

Digital Signature Layih nin r msal imzas  mü yy n etm k
olar.

Add-Ins
Add in Manager Add in Manager-i yükl yir. Behavior

xüsusiyy tli obyektl rin özl rini aparmaq
qaydas  d yi k üçün n rd  tutulub.

Window
Split VB redaktorunun Code p nc sini 2 yer  bölür

 bununla ilkin kodun 2 müxt lif s trind
(m n, 2 müxt lif prosedur v  ya modulda)

 imkan verir.

Tile Horizontally Layih  mövcud olan bütün UserForm, Module,
Class tipli m tnl ri v  formalar üfiqi kild
ayr -ayr  p nc  yerl dirir.

Tile Vertically Layih  mövcud olan bütün UserForm, Module,
Class tipli m tnl ri v  formalar aquli kild
ayr -ayr  p nc  yerl dirir.
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Cascade Layih  mövcud olan bütün UserForm, Module,
Class tipli m tnl ri v  formalar kaskad2 kild
ayr -ayr  p nc  yerl dirir.

Arrange Icons konlar  ard l kild  nizamlay r.

Help
Microsoft Visual Basic Help F1 VBA il  ba  bütün texniki s dl rin toplumu

olub, proqramç lar t find n geni  istifad  olunur
 3 m lumat kitab ndan ibar tdir3:

Microsoft Excel Visual Basic Reference
Microsoft Visual Basic Documentation
Microsoft Office Visual Basic Reference

MSDN on the Web Microsoft platformas nda i n proqramç lara
yard m m qs diy  yarad lm  Web m nb . r
proqramç  Microsoft Visual Basic Help rejimind
öz sual na cavab tapa bilmirs  o zaman
MSDN(Microsoft Developers Network)-nin
lokal v  ya Web m nb rin  müraci t ed  bil r.
Burada VBA il  ba  praktik olaraq bütün
suallara cavab tapa bil rsiz.

About Microsoft Visual Basic VBA il  ba  m lumat rejimi. Mü llifl r, versiya
kimi m lumatlar burada yerl dirilib. Bundan
ba qa bu rejim  WindowsXX liyyat
sisteminin “System Info” alt-sistemi qo ulub. Bu
alt-sistem vasit sil  siz liyyat sistemi,
kompüterinizin avadanl , fiziki parametrl r v
dig r m lumatlar ld  ed  bil rsiz.

VB redaktorunun al tl r panell ri
Praktik olaraq mövcud bütün kompüter sisteml rinin imkanlar  onun menyu paneli alt-sistemind
realiz  olunub. Bu m nada VB redaktoru da istisna deyil. Amma bu sisteml rl  i n zaman h r
hans  rejim  menyu vasit sil  müraci t sür tinin a  olmas lav  probleml r yarad r. stifad çinin
sistemd n istifad  sür tini art rmaq üçün istifad  olunan üsullardan birid  vacib rejiml ri(çox
istifad  olunan) özünd  saxlayan paneli xarakterli alt-siteml rd n, o cüml n, “Al tl r

nc ri”nd n istifad  olunur. A dak  c dv ll rd  biz VB redaktorunda istifad  olunan 4
al tl r panelil  tan  olaca q.
!!! Al tl r panelind ki düym rin(icon-lar) say  art b-azaltmaq v  bu düym  menyuda
realiz  olunmu  dig r rejiml rid  ba lamaq mümkündür. Bax: VB redaktorunun alt r p nc sin
yeni düym /rejimin lav  olunmas

Standard al tl r paneli
kil2. Standart al tl r panelinin görünü ü

View <host application> View -> <Host application> rejimi yükl nir.

2 P nc r bir birinin üz rind , p nc  ba qlar  görünm kl  düzülür.
3 Çox aktual bir m  oldu unu n  alaraq növb ti bölm  bu rejim daha trafl  izah olunacaq.
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Insert UserForm Bu multi-button (çox rejimli düym dir). Buradan layih
UserForm, Module, Class Module, Procedure lav  etm k olar.
Faktiki bu düym  vasit sil  Insert menyusundak :

UserForm
Module
Class Module
Procedure

rejiml ri yerin  yetirm k mümükündür.

Save File -> Save rejimi

Cut Edit -> Cut rejimi

Copy Edit -> Copy rejimi

Paste Edit -> Paste rejimi

Find Edit -> Find rejimi

Undo Edit -> Undo rejimi

Redo Edit -> Redo rejimi

Run Macro Run -> Run Sub/User Form rejimi

Break Run -> Break rejimi

Design Mode Run -> Design Mode rejimi

Reset Run -> Resert <project> rejimi

Project Explorer View -> Project Explorer rejimi

Properties Window View -> Properties Window rejimi

Object Browser View -> Object Browser rejimi

Toolbox View -> Toolbox rejimi

Microsoft Visual Basic Help Help -> Microsoft Visual Basic Help rejimi
Edit, Debug, UserForm al tl r panell ri VB redaktorunun yarad lar  t find n avtomatik
yükl nm  qo ulmay blar. Çünkü bu düym /rejiml r daha çox istifad  olundu u üçün, onlar n
ça lmas nda isti düym rd n istifad  daha m qs uy undur4. stifad çi öz ist yi il  bu
panell ri VB redaktora qo ub/ay ra bil r. Bu al t panell rinin xarici görnü ri a dak  kimididir:

Edit al tl r paneli

Debug al tl r paneli

4 Bu al tl r panelind ki düym /rejiml r VB redaktorunun menyu paneli alt-sistemind ki rejiml rin düym
ba lant ndan ba qa bir ey deyil. “Standart al tl r paneli”nd  oldu u kimi bu düym /rejiml rin mü yy n olunmas

ini t  bu bölm nini “Praktikum” hiss sind  s rb st bir tap q kimi mü yy n etmi ik.
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UseForm al tl r paneli

Praktikum
1. “Edit al tl r paneli”nin düym /rejiml ri VB redaktoru menyusunun hans  rejimin

uy undur?
2.  “Debug al tl r paneli”nin düym /rejiml ri VB redaktoru menyusunun hans  rejimin

uy undur?
3. “UserForm al tl r paneli”nin düym /rejiml ri VB redaktoru menyusunun hans  rejimin

uy undur?
4. Toggle Breakpoint rejimini “Standard al tl r paneli”n lav  edin.
5. Immediate Window rejimini “Edit al tl r paneli”n lav  edin.
6. Code v Object  rejiml rini “Debug al tl r paneli”n lav  edin.
7. Quick Watch rejimini “Debug al tl r paneli”nd n y n.
8. Quick Watch rejimini “Debug” menyusundan y n.
9. Code v Object  rejiml rini “Debug” menyusuna lav  edin.
10. VB redaktorunun al tl r panelind ki düym /rejiml rin icon-lar n haz rlay n.
11. Al tl r panell ri il  ba  Praktikum m ri haz rlay n (P)
12. Menyu paneli il  ba  Praktikum m ri haz rlay n (P)
13. VB redaktorunun p nc ri il  ba izzahl  test tap qlar  t rtib edin (P)
14. VB redaktorunun menyu paneli il  ba  ba izzahl  test tap qlar  t rtib edin (P)
15. VB redaktorunun al tl r paneli il  ba izzahl  test tap qlar  t rtib edin (P)
16. lkin m nb  kimi bölm nin materiallar ndan istifad  ed k bu bölm  istifad  olunan

ingilis söz v  istilahlar n t rcüm rini (rus, az rbaycan) v  bunlarla ba  izahlar
“ ngilis/Rus/Az rbaycan dilind  izzahl  terminaloji lü t” bölm sin  daxil etm k üçün
haz rlamaq.(P)

17. VB redaktorunda 2 din hasilini hesablayan forma-proseduru yaz n.


